What’s Vulnerable › Vulnerabilities
CVE-2025-64152: Apache IoTDB: Path Traversal Vulnerability
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-09-29
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.6 and 2.0.7, which fixes the issue.
Affected products
- Apache Software Foundation Apache IoTDB: from 1.0.0 before 1.3.6; from 2.0.0 before 2.0.7 — fixed in 1.3.6, 2.0.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.6, 2.0.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/sjms84rlt4g78fwmjcowxmtjp1q8b9q4
- http://www.openwall.com/lists/oss-security/2026/03/09/3
Get alerted when CVE-2025-64152 or the next vulnerability affects your stack