What’s Vulnerable › Vulnerabilities
CVE-2025-64163: DataEase's DB2 is vulnerable to SSRF
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-06 · updated 2026-10-19
- Weakness: CWE-918
Description
DataEase is an open source data visualization analysis tool. In versions 2.10.14 and below, the vendor added a blacklist to filter ldap:// and ldaps://. However, omission of protection for the dns:// protocol results in an SSRF vulnerability. This issue is fixed in version 2.10.15.
Affected products
- dataease: before 2.10.15 — fixed in 2.10.15
How to fix
Upgrade to a fixed version: dataease 2.10.15. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/869b7fb8b10069ac6c326554bfa8f060a539ba85
- https://github.com/dataease/dataease/releases/tag/v2.10.15
- https://github.com/dataease/dataease/security/advisories/GHSA-8397-v66p-539m
Get alerted when CVE-2025-64163 or the next vulnerability affects your stack