What’s Vulnerable › Vulnerabilities
CVE-2025-64164: DataEase is vulnerable to Oracle JNDI Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-06 · updated 2026-10-19
- Weakness: CWE-502
Description
Dataease is an open source data visualization analysis tool. In versions 2.10.14 and below, DataEase did not properly filter when establishing JDBC connections to Oracle, resulting in a risk of JNDI injection (Java Naming and Directory Interface injection). This issue is fixed in version 2.10.15.
Affected products
- dataease: before 2.10.15 — fixed in 2.10.15
How to fix
Upgrade to a fixed version: dataease 2.10.15. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/7b68eb3dfccbbd12ec977e6320dbd3e32a7bbfe6
- https://github.com/dataease/dataease/releases/tag/v2.10.15
- https://github.com/dataease/dataease/security/advisories/GHSA-q754-4pc2-wjqw
Get alerted when CVE-2025-64164 or the next vulnerability affects your stack