What’s Vulnerable › Vulnerabilities
CVE-2025-64166: Mercurius: Incorrect Content-Type parsing can lead to CSRF attack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-352
Description
Mercurius is a GraphQL adapter for Fastify. Prior to version 16.4.0, a cross-site request forgery (CSRF) vulnerability was identified. The issue arises from incorrect parsing of the Content-Type header in requests. Specifically, requests with Content-Type values such as application/x-www-form-urlencoded, multipart/form-data, or text/plain could be misinterpreted as application/json. This misinterpretation bypasses the preflight checks performed by the fetch() API, potentially allowing unauthorized actions to be performed on behalf of an authenticated user. This issue has been patched in version 16.4.0.
Affected products
- mercurius-js mercurius: before 16.4.0 — fixed in 16.4.0
How to fix
Upgrade to a fixed version: mercurius-js mercurius 16.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/mercurius-js/mercurius/commit/962d402ec7a92342f4a1b7f5f04af01776838c3c
- https://github.com/mercurius-js/mercurius/pull/1187
- https://github.com/mercurius-js/mercurius/security/advisories/GHSA-v66j-6wwf-jc57
- https://github.com/mercurius-js/mercurius/security/advisories/GHSA-v66j-6wwf-jc57
Get alerted when CVE-2025-64166 or the next vulnerability affects your stack