What’s Vulnerable › Vulnerabilities
CVE-2025-64173: Apollo Router Core: Access Control Bypass on Polymorphic Types
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-06 · updated 2026-06-17
- Weakness: CWE-288
Description
Apollo Router Core is a configurable graph router written in Rust to run a federated supergraph using Apollo Federation 2. In versions 1.61.11 below, as well as 2.0.0-alpha.0 through 2.8.1-rc.0, a vulnerability allowed for unauthenticated queries to access data that required additional access controls. Router incorrectly handled access control directives on interface types/fields and their implementing object types/fields, applying them to interface types/fields while ignoring directives on their implementing object types/fields when all implementations had the same requirements. Apollo Router customers defining @authenticated, @requiresScopes, or @policy directives inconsistently on polymorphic types (i.e., object types that implement interface types) are impacted. This issue is fixed in versions 1.61.12 and 2.8.1.
Affected products
- apollographql router: before 1.61.12; from 2.8.1-rc.0, < 2.8.1
References
- https://github.com/apollographql/router/releases/tag/v2.8.1
- https://github.com/apollographql/router/security/advisories/GHSA-x33c-7c2v-mrj9
- https://www.apollographql.com/docs/graphos/routing/security/authorization#authorization-directives
Get alerted when CVE-2025-64173 or the next vulnerability affects your stack