What’s Vulnerable › Vulnerabilities
CVE-2025-64174: OpenMage is vulnerable to XSS in Admin Notifications
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.
Affected products
- OpenMage magento-lts: before 20.16.0 — fixed in 20.16.0
How to fix
Upgrade to a fixed version: OpenMage magento-lts 20.16.0. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/9d604f5489851c54a96fca31b0e13c414b0fb20a
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-qv78-c8hc-438r
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-qv78-c8hc-438r
Get alerted when CVE-2025-64174 or the next vulnerability affects your stack