What’s Vulnerable › Vulnerabilities
CVE-2025-64175: Gogs Vulnerable to 2FA Bypass via Recovery Code
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-287
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, Gogs’ 2FA recovery code validation does not scope codes by user, enabling cross-account bypass. If an attacker knows a victim’s username and password, they can use any unused recovery code (e.g., from their own account) to bypass the victim’s 2FA. This enables full account takeover and renders 2FA ineffective in all environments where it's enabled.. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Affected products
- gogs: before 0.13.4 — fixed in 0.13.4
How to fix
Upgrade to a fixed version: gogs 0.13.4. Check the vendor advisory for mitigations.
References
- https://github.com/gogs/gogs/security/advisories/GHSA-p6x6-9mx6-26wj
- https://github.com/gogs/gogs/security/advisories/GHSA-p6x6-9mx6-26wj
Get alerted when CVE-2025-64175 or the next vulnerability affects your stack