What’s Vulnerable › Vulnerabilities
CVE-2025-64182: OpenEXR has buffer overflow in PyOpenEXR_old's channels() and channel()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-10 · updated 2026-06-17
- Weakness: CWE-120
Description
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. In versions 3.2.0 through 3.2.4, 3.3.0 through 3.3.5, and 3.4.0 through 3.4.2, a memory safety bug in the legacy OpenEXR Python adapter (the deprecated OpenEXR.InputFile wrapper) allow crashes and likely code execution when opening attacker-controlled EXR files or when passing crafted Python objects. Integer overflow and unchecked allocation in InputFile.channel() and InputFile.channels() can lead to heap overflow (32 bit) or a NULL deref (64 bit). Versions 3.2.5, 3.3.6, and 3.4.3 contain a patch for the issue.
Affected products
- AcademySoftwareFoundation openexr: from 3.2.0 before 3.2.5; from 3.3.0 before 3.3.6; from 3.4.0 before 3.4.3 — fixed in 3.2.5, 3.3.6, 3.4.3
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 3.2.5, 3.3.6, 3.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/AcademySoftwareFoundation/openexr/blob/b3a19903db0672c63055023aa788e592b16ec3c5/src/wrappers/python/PyOpenEXR_old.cpp#L528-L536
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vh63-9mqx-wmjr
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vh63-9mqx-wmjr
Get alerted when CVE-2025-64182 or the next vulnerability affects your stack