What’s Vulnerable › Vulnerabilities
CVE-2025-64187: OctoPrint is vulnerable to XSS through Action Command Notifications and Prompts
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-06-17
- Weakness: CWE-80
Description
OctoPrint provides a web interface for controlling consumer 3D printers. Versions 1.11.3 and below are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notifications and prompts popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. This issue is fixed in version 1.11.4.
Affected products
- OctoPrint: before 1.11.4 — fixed in 1.11.4
How to fix
Upgrade to a fixed version: OctoPrint 1.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/OctoPrint/OctoPrint/commit/9112e07b1085f4c1ee9eefc67985809251057a44
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-crvm-xjhm-9h29
Get alerted when CVE-2025-64187 or the next vulnerability affects your stack