What’s Vulnerable › Vulnerabilities
CVE-2025-64258: WordPress Follow My Blog Post plugin <= 2.3.9 - Sensitive Data Exposure vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-06-17
- Weakness: CWE-497
Description
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in wpweb Follow My Blog Post follow-my-blog-post allows Retrieve Embedded Sensitive Data.This issue affects Follow My Blog Post: from n/a through <= 2.3.9.
Affected products
- wpweb Follow My Blog Post: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: wpweb Follow My Blog Post 2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64258 or the next vulnerability affects your stack