What’s Vulnerable › Vulnerabilities
CVE-2025-64325: Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-18 · updated 2026-10-18
- Weakness: CWE-79
Description
Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.
Affected products
- EmbySupport Emby.Security: before 4.8.1.0 — fixed in 4.8.1.0
How to fix
Upgrade to a fixed version: EmbySupport Emby.Security 4.8.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/EmbySupport/Emby.Security/security/advisories/GHSA-2gwc-988r-2r7x
- https://github.com/EmbySupport/Emby.Security/security/advisories/GHSA-2gwc-988r-2r7x
Get alerted when CVE-2025-64325 or the next vulnerability affects your stack