What’s Vulnerable › Vulnerabilities
CVE-2025-64329: containerd CRI server: Host memory exhaustion through Attach goroutine leak
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-06-17
- Weakness: CWE-401
Description
containerd is an open-source container runtime. Versions 1.7.28 and below, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4, and 2.2.0-beta.0 through 2.2.0-rc.1 contain a bug in the CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. To workaround this vulnerability, users can set up an admission controller to control accesses to pods/attach resources.
Affected products
- containerd: before 1.7.29; from 2.0.0 before 2.0.7; from 2.1.0 before 2.1.5; 2.2.0-beta0, 2.2.0-beta1, 2.2.0-beta2, 2.2.0-rc0, 2.2.0-rc1 — fixed in 1.7.29, 2.0.7, 2.1.5
How to fix
Upgrade to a fixed version: containerd 1.7.29, 2.0.7, 2.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/containerd/containerd/commit/083b53cd6f19b5de7717b0ce92c11bdf95e612df
- https://github.com/containerd/containerd/security/advisories/GHSA-m6hq-p25p-ffr2
Get alerted when CVE-2025-64329 or the next vulnerability affects your stack