What’s Vulnerable › Vulnerabilities
CVE-2025-64332: Suricata is vulnerable to a stack overflow on larger compressed data
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-26 · updated 2026-10-18
- Weakness: CWE-121
Description
Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Prior to versions 7.0.13 and 8.0.2, a stack overflow that causes Suricata to crash can occur if SWF decompression is enabled. This issue has been patched in versions 7.0.13 and 8.0.2. A workaround for this issue involves disabling SWF decompression (swf-decompression in suricata.yaml), it is disabled by default; set decompress-depth to lower than half your stack size if swf-decompression must be enabled.
Affected products
- OISF suricata: before 7.0.13; from 8.0.0 before 8.0.2 — fixed in 7.0.13, 8.0.2
How to fix
Upgrade to a fixed version: OISF suricata 7.0.13, 8.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/OISF/suricata/commit/ad446c9006a77490af51c468aae0ce934f4d2117
- https://github.com/OISF/suricata/security/advisories/GHSA-p32q-7wcp-gv92
Get alerted when CVE-2025-64332 or the next vulnerability affects your stack