What’s Vulnerable › Vulnerabilities
CVE-2025-64340: FastMCP has a Command Injection vulnerability - Gemini CLI
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-03 · updated 2026-07-24
- Weakness: CWE-78
Description
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.
Affected products
- jlowin fastmcp: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: jlowin fastmcp 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/PrefectHQ/fastmcp/pull/3522
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g
- https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-m8x7-r2rg-vh5g
Get alerted when CVE-2025-64340 or the next vulnerability affects your stack