What’s Vulnerable › Vulnerabilities
CVE-2025-64347: Apollo Router Improperly Enforces Renamed Access Control Directives
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-06-17
- Weakness: CWE-284
Description
Apollo Router Core is a configurable Rust graph router written to run a federated supergraph using Apollo Federation 2. Versions 1.61.12-rc.0 and below and 2.8.1-rc.0 allow unauthorized access to protected data through schema elements with access control directives (@authenticated, @requiresScopes, and @policy) that were renamed via @link imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. This issue is fixed in versions 1.61.12 and 2.8.1.
Affected products
- apollographql router: before 1.61.12; from 2.8.1-rc.0, < 2.8.1
References
- https://github.com/apollographql/router/commit/78e4b20a2fc26cc5f141aa47992ed85375266a2b
- https://github.com/apollographql/router/security/advisories/GHSA-g8jh-vg5j-4h3f
Get alerted when CVE-2025-64347 or the next vulnerability affects your stack