What’s Vulnerable › Vulnerabilities
CVE-2025-64407: Apache OpenOffice: URL fetching can be used to exfiltrate arbitrary INI file values and environment variables
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-12 · updated 2026-10-18
- Weakness: CWE-201
Description
Apache OpenOffice documents can contain links. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt. Such links could also be used to transmit system information, such as environment variables or configuration settings. In the affected versions of Apache OpenOffice, documents that used a certain URI scheme linking to external files would load the contents of such files without prompting the user for permission to do so. Such URI scheme allows to include system configuration data, that is not supposed to be transmitted externally. This issue affects Apache OpenOffice: through 4.1.15. Users are recommended to upgrade to version 4.1.16, which fixes the issue. The LibreOffice suite reported this issue as CVE-2024-12426.
Affected products
- Apache Software Foundation Apache OpenOffice: before 4.1.16 — fixed in 4.1.16
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 4.1.16. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4yg1gv71f14fw4ky4ds50o6xjq49594g
- https://www.openoffice.org/security/cves/CVE-2025-64407.html
Get alerted when CVE-2025-64407 or the next vulnerability affects your stack