What’s Vulnerable › Vulnerabilities
CVE-2025-64408: Apache Causeway: Java deserialization vulnerability to authenticated attackers
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-502
Description
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges. This issue affects all current versions. Users are recommended to upgrade to version 3.5.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Causeway: from 2.0.0 before 3.5.0; 4.0.0-m1 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Causeway 3.5.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/rjlg4spqhmgy1xgq9wq5h2tfnq4pm70b
- http://www.openwall.com/lists/oss-security/2025/11/19/1
Get alerted when CVE-2025-64408 or the next vulnerability affects your stack