What’s Vulnerable › Vulnerabilities
CVE-2025-64421: Coolify has a privilege escalation - low privileged user can invite themselves as an admin user
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-05 · updated 2026-10-07
- Weakness: CWE-863
Description
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. In Coolify versions up to and including v4.0.0-beta.434, a low privileged user (member) can invite a high privileged user. At first, the application will throw an error, but if the attacker clicks the invite button a second time, it actually works. This way, a low privileged user can invite themselves as an administrator to the Coolify instance. After the high privileged user is invited, the attacker can initiate a password reset and log in with the new admin. As of time of publication, it is unclear if a patch is available.
Affected products
- coollabsio coolify: before 4.0.0; 4.0.0-beta100, 4.0.0-beta101, 4.0.0-beta102, 4.0.0-beta103, 4.0.0-beta104, 4.0.0-beta105 (+418) — fixed in 4.0.0
How to fix
Upgrade to a fixed version: coollabsio coolify 4.0.0. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1YZHFgiZv_k9p9909A63DAErsTsh8K1rc/view?usp=drive_link
- https://github.com/coollabsio/coolify/security/advisories/GHSA-4p6r-m39m-9cm9
Get alerted when CVE-2025-64421 or the next vulnerability affects your stack