What’s Vulnerable › Vulnerabilities
CVE-2025-64424: Colify has command injection vulnerability in project git source
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-05 · updated 2026-10-07
- Weakness: CWE-77
Description
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. In Coolify versions up to and including v4.0.0-beta.434, a command injection vulnerability exists in the git source input fields of a resource, allowing a low privileged user (member) to execute system commands as root on the Coolify instance. As of time of publication, it is unclear if a patch is available.
Affected products
- coollabsio coolify: before 4.0.0; 4.0.0-beta100, 4.0.0-beta101, 4.0.0-beta102, 4.0.0-beta103, 4.0.0-beta104, 4.0.0-beta105 (+418) — fixed in 4.0.0
How to fix
Upgrade to a fixed version: coollabsio coolify 4.0.0. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1rk7AYxNDkJUwo8uWbzX62PpBxpDYeyrZ/view?usp=drive_link
- https://github.com/coollabsio/coolify/security/advisories/GHSA-qx24-jhwj-8w6x
- https://github.com/coollabsio/coolify/security/advisories/GHSA-qx24-jhwj-8w6x
Get alerted when CVE-2025-64424 or the next vulnerability affects your stack