What’s Vulnerable › Vulnerabilities
CVE-2025-64428: DataEase DB2 JNDI Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-20 · updated 2026-10-19
- Weakness: CWE-74
Description
Dataease is an open source data visualization analysis tool. Versions prior to 2.10.17 are vulnerable to JNDI injection. A blacklist was added in the patch for version 2.10.14. However, JNDI injection remains possible via the iiop, corbaname, and iiopname schemes. The vulnerability has been fixed in version 2.10.17.
Affected products
- dataease: before 2.10.17 — fixed in 2.10.17
How to fix
Upgrade to a fixed version: dataease 2.10.17. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/b7e585c1cc3fc2b73cb289b8680b4b3914be3d53
- https://github.com/dataease/dataease/releases/tag/v2.10.17
- https://github.com/dataease/dataease/security/advisories/GHSA-88ph-3236-2m2h
- https://github.com/dataease/dataease/security/advisories/GHSA-88ph-3236-2m2h
Get alerted when CVE-2025-64428 or the next vulnerability affects your stack