What’s Vulnerable › Vulnerabilities
CVE-2025-64432: KubeVirt Affected by an Authentication Bypass in Kubernetes Aggregation Layer
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-07 · updated 2026-06-17
- Weakness: CWE-287
Description
KubeVirt is a virtual machine management add-on for Kubernetes. Versions 1.5.3 and below, and 1.6.0 contained a flawed implementation of the Kubernetes aggregation layer's authentication flow which could enable bypass of RBAC controls. It was discovered that the virt-api component fails to correctly authenticate the client when receiving API requests over mTLS. In particular, it fails to validate the CN (Common Name) field in the received client TLS certificates against the set of allowed values defined in the extension-apiserver-authentication configmap. Failre to validate certain fields in the client TLS certificate may allow an attacker to bypass existing RBAC controls by directly communicating with the aggregated API server, impersonating the Kubernetes API server and its aggregator component. This issue is fixed in versions 1.5.3 and 1.6.1.
Affected products
- kubevirt: before 1.5.3; 1.6.0, 1.6.0-rc0, 1.6.0-rc1 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: kubevirt 1.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/kubevirt/kubevirt/commit/231dc69723f331dc02f65a31ab4c3d6869f40d6a
- https://github.com/kubevirt/kubevirt/commit/af2f08a9a186eccc650f87c30ab3e07b669e8b5b
- https://github.com/kubevirt/kubevirt/commit/b9773bc588e6e18ece896a2dad5336ef7a653074
- https://github.com/kubevirt/kubevirt/security/advisories/GHSA-38jw-g2qx-4286
Get alerted when CVE-2025-64432 or the next vulnerability affects your stack