What’s Vulnerable › Vulnerabilities
CVE-2025-6444: ServiceStack GetErrorResponse Improper Input Validation NTLM Relay Vulnerability
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-20
Description
ServiceStack GetErrorResponse Improper Input Validation NTLM Relay Vulnerability. This vulnerability allows remote attackers to relay NTLM credentials on affected installations of ServiceStack. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the implementation of the GetErrorResponse method. The issue results from the lack of proper validation of user-supplied data, which can result in a type confusion condition. An attacker can leverage this vulnerability to relay NTLM credentials in the context of the current user. Was ZDI-CAN-25834.
Affected products
- ServiceStack: before 8.6 — fixed in 8.6
How to fix
Upgrade to a fixed version: ServiceStack 8.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6444 or the next vulnerability affects your stack