What’s Vulnerable › Vulnerabilities
CVE-2025-64457
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-10 · updated 2026-09-26
- Weakness: CWE-367
Description
In JetBrains ReSharper, Rider and dotTrace before 2025.2.5 local privilege escalation was possible via race condition
Affected products
- JetBrains dotTrace: before 2025.2.5 — fixed in 2025.2.5
- JetBrains ReSharper: before 2025.2.5 — fixed in 2025.2.5
- JetBrains Rider: before 2025.2.5 — fixed in 2025.2.5
How to fix
Upgrade to a fixed version: JetBrains dotTrace 2025.2.5; JetBrains ReSharper 2025.2.5; JetBrains Rider 2025.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64457 or the next vulnerability affects your stack