What’s Vulnerable › Vulnerabilities

CVE-2025-64460: Potential denial-of-service vulnerability in XML serializer text extraction

Description

An issue was discovered in 5.2 before 5.2.9, 5.1 before 5.1.15, and 4.2 before 4.2.27. Algorithmic complexity in `django.core.serializers.xml_serializer.getInnerText()` allows a remote attacker to cause a potential denial-of-service attack triggering CPU and memory exhaustion via specially crafted XML input processed by the XML `Deserializer`. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Seokchan Yoon for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 4.2.27, 5.1.15, 5.2.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-64460 or the next vulnerability affects your stack