What’s Vulnerable › Vulnerabilities
CVE-2025-64498: Tuleap has a Cross-Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-07
- Weakness: CWE-352
Description
Tuleap is an Open Source Suite for management of software development and collaboration. Tuleap Community Edition versions below 17.0.99.1762444754 and Tuleap Enterprise Edition versions prior to 17.0-2, 16.13-7 and 16.12-10 allow attackers trick victims into changing tracker general settings. This issue is fixed in version Tuleap Community Edition version 17.0.99.1762444754 and Tuleap Enterprise Edition versions 17.0-2, 16.13-7 and 16.12-10.
Affected products
- Enalean tuleap: before 16.12-10; before 17.0.99.1762444754; from 16.13 before 16.13-7; from 17.0 before 17.0-2 — fixed in 16.12-10, 16.13-7, 17.0-2, 17.0.99.1762444754
How to fix
Upgrade to a fixed version: Enalean tuleap 16.12-10, 16.13-7, 17.0-2, 17.0.99.1762444754. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/993316dd6a291bb3937cb7a4571eaab0e7d55370
- https://github.com/Enalean/tuleap/security/advisories/GHSA-vxfh-h8p6-p5rg
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=993316dd6a291bb3937cb7a4571eaab0e7d55370
- https://tuleap.net/plugins/tracker/?aid=45593
Get alerted when CVE-2025-64498 or the next vulnerability affects your stack