What’s Vulnerable › Vulnerabilities
CVE-2025-64500: Symfony's incorrect parsing of PATH_INFO can lead to limited authorization bypass
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-12 · updated 2026-10-19
- Weakness: CWE-647
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Symfony's HttpFoundation component defines an object-oriented layer for the HTTP specification. Starting in version 2.0.0 and prior to version 5.4.50, 6.4.29, and 7.3.7, the `Request` class improperly interprets some `PATH_INFO` in a way that leads to representing some URLs with a path that doesn't start with a `/`. This can allow bypassing some access control rules that are built with this `/`-prefix assumption. Starting in versions 5.4.50, 6.4.29, and 7.3.7, the `Request` class now ensures that URL paths always start with a `/`.
Affected products
- Sensiolabs Httpfoundation: from 2.0.0 before 5.4.50; from 6.0.0 before 6.4.29; from 7.0.0 before 7.3.7 — fixed in 5.4.50, 6.4.29, 7.3.7
- symfony: from 2.0.0 before 5.4.50; from 6.0.0 before 6.4.29; from 7.0.0 before 7.3.7 — fixed in 5.4.50, 6.4.29, 7.3.7
- Packagist Symfony/Http-Foundation: before 5.4.50; from 6.0.0 before 6.4.29; from 7.0.0 before 7.3.7; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.12 (+621) — fixed in 5.4.50, 6.4.29, 7.3.7
- Packagist Symfony/Symfony: from 2.0.0 before 5.4.50; from 6.0.0 before 6.4.29; from 7.0.0 before 7.3.7; 2.0.4, 2.0.5, 2.0.6, 2.0.7, v2.0.10, v2.0.11 (+651) — fixed in 5.4.50, 6.4.29, 7.3.7
How to fix
Upgrade to a fixed version: Sensiolabs Httpfoundation 5.4.50, 6.4.29, 7.3.7; symfony 5.4.50, 6.4.29, 7.3.7; Packagist Symfony/Http-Foundation 5.4.50, 6.4.29, 7.3.7; Packagist Symfony/Symfony 5.4.50, 6.4.29, 7.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/http-foundation/CVE-2025-64500.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2025-64500.yaml
- https://github.com/symfony/symfony/commit/9962b91b12bb791322fa73836b350836b6db7cac
- https://github.com/symfony/symfony/security/advisories/GHSA-3rg7-wf37-54rm
- https://symfony.com/blog/cve-2025-64500-incorrect-parsing-of-path-info-can-lead-to-limited-authorization-bypass
Get alerted when CVE-2025-64500 or the next vulnerability affects your stack