What’s Vulnerable › Vulnerabilities
CVE-2025-64505: LIBPNG is vulnerable to a heap buffer overflow in `png_do_quantize` via malformed palette index
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-125
Description
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to version 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_do_quantize function when processing PNG files with malformed palette indices. The vulnerability occurs when palette_lookup array bounds are not validated against externally-supplied image data, allowing an attacker to craft a PNG file with out-of-range palette indices that trigger out-of-bounds memory access. This issue has been patched in version 1.6.51.
Affected products
- pnggroup libpng: before 1.6.51 — fixed in 1.6.51
How to fix
Upgrade to a fixed version: pnggroup libpng 1.6.51. Check the vendor advisory for mitigations.
References
- https://github.com/pnggroup/libpng/commit/6a528eb5fd0dd7f6de1c39d30de0e41473431c37
- https://github.com/pnggroup/libpng/pull/748
- https://github.com/pnggroup/libpng/security/advisories/GHSA-4952-h5wq-4m42
Get alerted when CVE-2025-64505 or the next vulnerability affects your stack