What’s Vulnerable › Vulnerabilities
CVE-2025-64506: LIBPNG is vulnerable to a heap buffer over-read in `png_write_image_8bit` with grayscale+alpha or RGB/RGBA images
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-125
Description
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_write_image_8bit function when processing 8-bit images through the simplified write API with convert_to_8bit enabled. The vulnerability affects 8-bit grayscale+alpha, RGB/RGBA, and images with incomplete row data. A conditional guard incorrectly allows 8-bit input to enter code expecting 16-bit input, causing reads up to 2 bytes beyond allocated buffer boundaries. This issue has been patched in version 1.6.51.
Affected products
- pnggroup libpng: from 1.6.0 before 1.6.51 — fixed in 1.6.51
How to fix
Upgrade to a fixed version: pnggroup libpng 1.6.51. Check the vendor advisory for mitigations.
References
- https://github.com/pnggroup/libpng/commit/2bd84c019c300b78e811743fbcddb67c9d9bf821
- https://github.com/pnggroup/libpng/pull/749
- https://github.com/pnggroup/libpng/security/advisories/GHSA-qpr4-xm66-hww6
Get alerted when CVE-2025-64506 or the next vulnerability affects your stack