What’s Vulnerable › Vulnerabilities
CVE-2025-64509: Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input (via CPU)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.6, a specially crafted Brotli-compressed envelope can cause Bugsink to spend excessive CPU time in decompression, leading to denial of service. This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink 2.0.6. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-fc2v-vcwj-269v/CVE-2025-64508.
Affected products
- bugsink: before 2.0.6
References
Get alerted when CVE-2025-64509 or the next vulnerability affects your stack