What’s Vulnerable › Vulnerabilities
CVE-2025-64520: GLPI vulnerable to unauthorized access to restricted Knowledge Base items through the API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-16 · updated 2026-10-13
- Weakness: CWE-862
Description
GLPI is a free asset and IT management software package. Starting in version 9.1.0 and prior to version 10.0.21, an unauthorized user with an API access can read all knowledge base entries. Users should upgrade to 10.0.21 to receive a patch.
Affected products
- glpi-project glpi: from 9.1.0 before 10.0.21 — fixed in 10.0.21
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.21. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/a3d5cc4a63ae592c0b5592ebe6d562164904dab3
- https://github.com/glpi-project/glpi/security/advisories/GHSA-62p9-prpq-j62q
Get alerted when CVE-2025-64520 or the next vulnerability affects your stack