What’s Vulnerable › Vulnerabilities

CVE-2025-6454: Server-Side Request Forgery (SSRF) in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed authenticated users to make unintended internal requests through proxy environments by injecting crafted sequences.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.1.6, 18.2.6, 18.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-6454 or the next vulnerability affects your stack