What’s Vulnerable › Vulnerabilities
CVE-2025-6462: EZ SQL Reports Shortcode Widget and DB Backup <= 5.25.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via SQLREPORT Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The EZ SQL Reports Shortcode Widget and DB Backup plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's SQLREPORT shortcode in all versions up to, and including, 5.25.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- scheeeli EZ SQL Reports Shortcode Widget and DB Backup: before 5.25.25 — fixed in 5.25.25
How to fix
Upgrade to a fixed version: scheeeli EZ SQL Reports Shortcode Widget and DB Backup 5.25.25. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3318513/
- https://wordpress.org/plugins/elisqlreports/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a6811f19-07fb-4c05-977f-90f9c5d89bb4?source=cve
Get alerted when CVE-2025-6462 or the next vulnerability affects your stack