What’s Vulnerable › Vulnerabilities
CVE-2025-6466: ageerle ruoyi-ai SseServiceImpl.java upload unrestricted upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-22 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability was found in ageerle ruoyi-ai 2.0.0 and classified as critical. Affected by this issue is the function speechToTextTranscriptionsV2/upload of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/service/impl/SseServiceImpl.java. The manipulation of the argument File leads to unrestricted upload. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as 4e93ac86d4891c59ecfcd27c051de9b3c5379315. It is recommended to upgrade the affected component.
Affected products
- ageerle ruoyi-ai: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: ageerle ruoyi-ai 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/ageerle/ruoyi-ai/commit/4e93ac86d4891c59ecfcd27c051de9b3c5379315
- https://github.com/ageerle/ruoyi-ai/issues/9
- https://github.com/ageerle/ruoyi-ai/issues/9#event-16775988438
- https://github.com/ageerle/ruoyi-ai/releases/tag/v2.0.1
- https://vuldb.com/?ctiid.313574
- https://vuldb.com/?id.313574
- https://vuldb.com/?submit.598365
- https://github.com/ageerle/ruoyi-ai/issues/9#event-16775988438
Get alerted when CVE-2025-6466 or the next vulnerability affects your stack