What’s Vulnerable › Vulnerabilities
CVE-2025-64720: LIBPNG is vulnerable to a buffer overflow in `png_image_read_composite` via incorrect palette premultiplication
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-125
Description
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.
Affected products
- pnggroup libpng: from 1.6.0 before 1.6.51 — fixed in 1.6.51
How to fix
Upgrade to a fixed version: pnggroup libpng 1.6.51. Check the vendor advisory for mitigations.
References
- https://github.com/pnggroup/libpng/commit/08da33b4c88cfcd36e5a706558a8d7e0e4773643
- https://github.com/pnggroup/libpng/issues/686
- https://github.com/pnggroup/libpng/pull/751
- https://github.com/pnggroup/libpng/security/advisories/GHSA-hfc7-ph9c-wcww
- https://github.com/pnggroup/libpng/security/advisories/GHSA-hfc7-ph9c-wcww
Get alerted when CVE-2025-64720 or the next vulnerability affects your stack