What’s Vulnerable › Vulnerabilities
CVE-2025-64747: Directus Vulnerable to Stored Cross-site Scripting
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-13 · updated 2026-10-19
- Weakness: CWE-20
Description
Directus is a real-time API and App dashboard for managing SQL database content. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 11.13.0 that allows users with `upload files` and `edit item` permissions to inject malicious JavaScript through the Block Editor interface. Attackers can bypass Content Security Policy (CSP) restrictions by combining file uploads with iframe srcdoc attributes, resulting in persistent XSS execution. Version 11.13.0 fixes the issue.
Affected products
- directus: before 11.13.0 — fixed in 11.13.0
How to fix
Upgrade to a fixed version: directus 11.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/directus/directus/commit/d23525317f0780f04aa1fe7a99171a358e43cb2e
- https://github.com/directus/directus/security/advisories/GHSA-vv2v-pw69-8crf
Get alerted when CVE-2025-64747 or the next vulnerability affects your stack