What’s Vulnerable › Vulnerabilities
CVE-2025-64749: Directus Vulnerable to Information Leakage in Existing Collections
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-13 · updated 2026-10-19
- Weakness: CWE-203
Description
Directus is a real-time API and App dashboard for managing SQL database content. An observable difference in error messaging was found in the Directus REST API in versions of Directus prior to version 11.13.0. The `/items/{collection}` API returns different error messages for two cases: when a user tries to access an existing collection which they are not authorized to access, and when user tries to access a non-existing collection. The two differing error messages leak the existence of collections to users which are not authorized to access these collections. Version 11.13.0 fixes the issue.
Affected products
- directus: before 11.13.0 — fixed in 11.13.0
How to fix
Upgrade to a fixed version: directus 11.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/directus/directus/commit/f99c9b89071f9d136cc9b0d0c182f2d24542bc31
- https://github.com/directus/directus/security/advisories/GHSA-cph6-524f-3hgr
Get alerted when CVE-2025-64749 or the next vulnerability affects your stack