What’s Vulnerable › Vulnerabilities

CVE-2025-64756: glob CLI: Command injection via -c/--cmd executes matches with shell:true

Description

Glob matches files using patterns the shell uses. Starting in version 10.2.0 and prior to versions 10.5.0 and 11.1.0, the glob CLI contains a command injection vulnerability in its -c/--cmd option that allows arbitrary command execution when processing files with malicious names. When glob -c <command> <patterns> are used, matched filenames are passed to a shell with shell: true, enabling shell metacharacters in filenames to trigger command injection and achieve arbitrary code execution under the user or CI account privileges. This issue has been patched in versions 10.5.0 and 11.1.0.

Affected products

How to fix

Upgrade to a fixed version: isaacs node-glob 10.5.0, 11.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-64756 or the next vulnerability affects your stack