What’s Vulnerable › Vulnerabilities
CVE-2025-64759: Homarr is Vulnerable to Stored Cross-Site Scripting (XSS) and Possible Privilege Escalation via Malicious SVG Upload
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-19
- Weakness: CWE-20
Description
Homarr is an open-source dashboard. Prior to version 1.43.3, stored XSS vulnerability exists, allowing the execution of arbitrary JavaScript in a user's browser, with minimal or no user interaction required, due to the rendering of a malicious uploaded SVG file. This could be abused to add an attacker's account to the "credentials-admin" group, giving them full administrative access, if a user logged in as an administrator was to view the page which renders or redirects to the SVG. This issue has been patched in version 1.43.3.
Affected products
- homarr-labs homarr: before 1.43.3 — fixed in 1.43.3
How to fix
Upgrade to a fixed version: homarr-labs homarr 1.43.3. Check the vendor advisory for mitigations.
References
- https://github.com/homarr-labs/homarr/commit/aaa23f37321be1e110f722b36889b2fd3bea2059
- https://github.com/homarr-labs/homarr/security/advisories/GHSA-wj62-c5gr-2x53
Get alerted when CVE-2025-64759 or the next vulnerability affects your stack