What’s Vulnerable › Vulnerabilities
CVE-2025-64761: OpenBao Privileged Operator Identity Group Root Escalation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-266
Description
OpenBao is an open source identity-based secrets management system. Prior to version 2.4.4, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: an operator in the root namespace has access to identity/groups endpoints and an operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. This issue has been patched in version 2.4.4.
Affected products
- openbao: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: openbao 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/commit/16bb0ccd37a502930a289d434cbe4e7b4edd66e5
- https://github.com/openbao/openbao/pull/2143
- https://github.com/openbao/openbao/security/advisories/GHSA-7ff4-jw48-3436
Get alerted when CVE-2025-64761 or the next vulnerability affects your stack