What’s Vulnerable › Vulnerabilities

CVE-2025-64775: Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS)

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 6.8.0, 7.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-64775 or the next vulnerability affects your stack