What’s Vulnerable › Vulnerabilities
CVE-2025-65017: Decidim's private data exports can lead to data leaks
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-200
Description
Decidim is a participatory democracy framework. In versions from 0.30.0 to before 0.30.4 and from 0.31.0.rc1 to before 0.31.0, the private data exports can lead to data leaks in case the UUID generation, causing collisions for the generated UUIDs. This issue has been patched in versions 0.30.4 and 0.31.0.
Affected products
- decidim: from 0.30.0 before 0.30.4; 0.31.0-rc1, 0.31.0-rc2 — fixed in 0.30.4
How to fix
Upgrade to a fixed version: decidim 0.30.4. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/pull/13571
- https://github.com/decidim/decidim/releases/tag/v0.30.4
- https://github.com/decidim/decidim/releases/tag/v0.31.0
- https://github.com/decidim/decidim/security/advisories/GHSA-3cx6-j9j4-54mp
Get alerted when CVE-2025-65017 or the next vulnerability affects your stack