What’s Vulnerable › Vulnerabilities
CVE-2025-65018: LIBPNG is vulnerable to a heap buffer overflow in `png_combine_row` triggered via `png_image_finish_read`
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-122
Description
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, there is a heap buffer overflow vulnerability in the libpng simplified API function png_image_finish_read when processing 16-bit interlaced PNGs with 8-bit output format. Attacker-crafted interlaced PNG files cause heap writes beyond allocated buffer bounds. This issue has been patched in version 1.6.51.
Affected products
- pnggroup libpng: from 1.6.0 before 1.6.51 — fixed in 1.6.51
How to fix
Upgrade to a fixed version: pnggroup libpng 1.6.51. Check the vendor advisory for mitigations.
References
- https://github.com/pnggroup/libpng/commit/16b5e3823918840aae65c0a6da57c78a5a496a4d
- https://github.com/pnggroup/libpng/commit/218612ddd6b17944e21eda56caf8b4bf7779d1ea
- https://github.com/pnggroup/libpng/issues/755
- https://github.com/pnggroup/libpng/pull/757
- https://github.com/pnggroup/libpng/security/advisories/GHSA-7wv6-48j4-hj3g
- https://github.com/pnggroup/libpng/issues/755
- https://github.com/pnggroup/libpng/security/advisories/GHSA-7wv6-48j4-hj3g
Get alerted when CVE-2025-65018 or the next vulnerability affects your stack