What’s Vulnerable › Vulnerabilities
CVE-2025-65019: Astro Cloudflare adapter has a Stored Cross Site Scripting vulnerability in /_image endpoint
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-79
Description
Astro is a web framework. Prior to version 5.15.9, when using Astro's Cloudflare adapter (@astrojs/cloudflare) with output: 'server', the image optimization endpoint (/_image) contains a critical vulnerability in the isRemoteAllowed() function that unconditionally allows data: protocol URLs. This enables Cross-Site Scripting (XSS) attacks through malicious SVG payloads, bypassing domain restrictions and Content Security Policy protections. This issue has been patched in version 5.15.9.
Affected products
- withastro astro: before 5.15.9 — fixed in 5.15.9
How to fix
Upgrade to a fixed version: withastro astro 5.15.9. Check the vendor advisory for mitigations.
References
- https://github.com/withastro/astro/commit/9e9c528191b6f5e06db9daf6ad26b8f68016e533
- https://github.com/withastro/astro/security/advisories/GHSA-fvmw-cj7j-j39q
Get alerted when CVE-2025-65019 or the next vulnerability affects your stack