What’s Vulnerable › Vulnerabilities
CVE-2025-65028: Rallly Has an IDOR Vulnerability in Vote Update Endpoint Allows Unauthorized Manipulation of Participant Votes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-285
Description
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an insecure direct object reference (IDOR) vulnerability allows any authenticated user to modify other participants’ votes in polls without authorization. The backend relies solely on the participantId parameter to identify which votes to update, without verifying ownership or poll permissions. This allows an attacker to alter poll results in their favor, directly compromising data integrity. This issue has been patched in version 4.5.4.
Affected products
- lukevella rallly: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: lukevella rallly 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/lukevella/rallly/releases/tag/v4.5.4
- https://github.com/lukevella/rallly/security/advisories/GHSA-pchc-v5hg-f5gp
Get alerted when CVE-2025-65028 or the next vulnerability affects your stack