What’s Vulnerable › Vulnerabilities
CVE-2025-65031: Rallly Improper Authorization in Comment Endpoint Allows User Impersonation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-285
Description
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization flaw in the comment creation endpoint allows authenticated users to impersonate any other user by altering the authorName field in the API request. This enables attackers to post comments under arbitrary usernames, including privileged ones such as administrators, potentially misleading other users and enabling phishing or social engineering attacks. This issue has been patched in version 4.5.4.
Affected products
- lukevella rallly: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: lukevella rallly 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/lukevella/rallly/releases/tag/v4.5.4
- https://github.com/lukevella/rallly/security/advisories/GHSA-hhfc-6gq7-rrpm
Get alerted when CVE-2025-65031 or the next vulnerability affects your stack