What’s Vulnerable › Vulnerabilities
CVE-2025-65033: Rallly Broken Authorization: Any User Can Pause or Resume Any Poll via Poll ID Manipulation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-285
Description
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an authorization flaw in the poll management feature allows any authenticated user to pause or resume any poll, regardless of ownership. The system only uses the public pollId to identify polls, and it does not verify whether the user performing the action is the poll owner. As a result, any user can disrupt polls created by others, leading to a loss of integrity and availability across the application. This issue has been patched in version 4.5.4.
Affected products
- lukevella rallly: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: lukevella rallly 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/lukevella/rallly/releases/tag/v4.5.4
- https://github.com/lukevella/rallly/security/advisories/GHSA-4p93-v53r-vch3
- https://github.com/lukevella/rallly/security/advisories/GHSA-4p93-v53r-vch3
Get alerted when CVE-2025-65033 or the next vulnerability affects your stack