What’s Vulnerable › Vulnerabilities
CVE-2025-65034: Rallly Improper Authorization Allows Reopening of Any Finalized Poll via Public pollId
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-639
Description
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization vulnerability allows any authenticated user to reopen finalized polls belonging to other users by manipulating the pollId parameter. This can disrupt events managed by other users and compromise both availability and integrity of poll data. This issue has been patched in version 4.5.4.
Affected products
- lukevella rallly: before 4.5.4 — fixed in 4.5.4
How to fix
Upgrade to a fixed version: lukevella rallly 4.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/lukevella/rallly/releases/tag/v4.5.4
- https://github.com/lukevella/rallly/security/advisories/GHSA-5fp2-pv2j-rqpc
- https://github.com/lukevella/rallly/security/advisories/GHSA-5fp2-pv2j-rqpc
Get alerted when CVE-2025-65034 or the next vulnerability affects your stack