What’s Vulnerable › Vulnerabilities
CVE-2025-6505
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-29 · updated 2026-06-17
- Weakness: CWE-287
Description
Unauthorized access and impersonation can occur in versions 4.6.2.3226 and below of Progress Software's Hybrid Data Pipeline Server on Linux. This vulnerability allows attackers to combine credentials from different sources, potentially leading to client impersonation and unauthorized access. When OAuth Clients perform an OAuth handshake with the Hybrid Data Pipeline Server, the server accepts client credentials from both HTTP headers and request parameters.
Affected products
- Progress Software Hybrid Data Pipeline: before 4.6.2.3275 — fixed in 4.6.2.3275
How to fix
Upgrade to a fixed version: Progress Software Hybrid Data Pipeline 4.6.2.3275. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6505 or the next vulnerability affects your stack