What’s Vulnerable › Vulnerabilities

CVE-2025-65082: Apache HTTP Server: CGI environment variable override

Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.66. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-65082 or the next vulnerability affects your stack