What’s Vulnerable › Vulnerabilities
CVE-2025-65095: Lookyloo is vulnerable due to improper user input sanitization
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-19
- Weakness: CWE-79
Description
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to version 1.35.1, there is potential cross-site scripting on index and tree page. This issue has been patched in version 1.35.1.
Affected products
- lookyloo: before 1.35.1
References
- https://github.com/Lookyloo/lookyloo/blob/main/website/web/default_csp.py
- https://github.com/Lookyloo/lookyloo/commit/ac2f73dbfcad88b815b18c42cca77a1c645f1726
- https://github.com/Lookyloo/lookyloo/security/advisories/GHSA-m9g6-23c8-vrxf
- https://vulnerability.circl.lu/vuln/gcve-1-2025-0018
Get alerted when CVE-2025-65095 or the next vulnerability affects your stack